Table of Contents

Section 1: Data Explorer Context .................................................................................................................................................................................. 2
  Section 1.1: Data Explorer Context (GIS) ............................................................................................................................ 2
  Section 1.2: Data Explorer Context (Web Services and USGIN) ...................................................................................... 3

Section 2: Using the NGDS Data Explorer .................................................................................................................................................. 3
  Section 2.1: Loading Web Services via Search and Dropdown Menu ...................................................................................... 4
  Section 2.2: Loading Web Services via URL ....................................................................................................................... 5
  Section 2.3: Exporting Data from the Data Explorer ............................................................................................................. 6
The National Geothermal Data System (NGDS) Data Explorer is a third-party web application, designed by Jessica Good Alisdairi of the Arizona Geological Survey to export attributes from live web feature services (WFS) into HTML tables, which act as an interchange format. Once exported into HTML tables, attributes can be saved to discrete files or copied and pasted into an appropriate application, such as Microsoft Excel.

This document provides instructions regarding access to, and usage of, the NGDS Data Explorer.

A link to the application can be found here: http://data.geothermaldataset.org/

Section 1: Data Explorer Context

The NGDS Data Explorer operates within three overlapping contexts:

1. Geographic Information Systems (GIS) software and associated concepts
2. Web services, specifically web feature services (WFS)
3. The United States Geoscience Information Network (USGIN)

Understanding the purpose and operation of the NGDS Data Explorer is facilitated by a general understanding of these three concepts.

Section 1.1: Data Explorer Context (GIS)

The NGDS Data Explorer is designed to interact with, and extract data from, GIS attribute tables. This section describes GIS attribute tables.

Geographic Information Systems are software applications designed to access, visualize, and analyze geospatial data. Most GIS applications approach this objective by combining cartographic software, database software, and statistical analysis software in one package.

ESRI ArcGIS is a well-known GIS application that represents real-world objects as cartographic features. Each feature in an ArcGIS document is described by a database record; each database record contains attributes, including the latitude-longitude position of the feature and other relevant information. This database, or attribute table, can be queried and used to perform statistical analysis.

For example, an ArcGIS attribute table might contain data describing features such as homes, power lines, and power plants in a given state. This attribute table would permit these features to be projected and displayed accurately on a map. In addition, if the attribute table contained information on power usage rates over time for each house in the dataset, it could be used to perform geospatial analysis on power usage in the area, in order to anticipate demand at any given location.
Web feature services (WFS), described further on the next page of this tutorial, use attribute tables; the NGDS Data Explorer is designed to query these attribute tables and extract data from them.

Section 1.2: Data Explorer Context (Web Services and USGIN)

The NGDS Data Explorer is designed to interact with, and extract data from, web services, specifically web feature services (WFS); consequently, some understanding of web services is useful.

A web service is a server-side protocol that responds to specific requests from client software applications. In response to these requests, web services access appropriately configured web-accessible resources on the server. As long as a request for web-accessible resources uses appropriate syntax, web services can respond. Web service syntax defines required input parameters, operation output, and the results of any operations performed.

Web services act as an intermediary between the client and the server, allowing the two systems to develop independently. This means that regardless of client or server make and model, regardless of changes to content on the server, a web service will be able to respond to requests as long as those requests are made using correct syntax.

The Open Geospatial Consortium has produced several different flavors of web service that are relevant to geographic information systems, USGIN, the National Geothermal Data System (NGDS), and the AASG Geothermal Data project. These include Web Feature Services (WFS), which provide georeferenced features described by attributes.

For example a feature service containing data about river systems might provide features with linear geometry representing river segments; each feature might be described by attributes such as average flow rate, width, and depth for the segment.

Feature services are useful for geospatial analysis. For example, a client application used to calculate the most efficient route between points in a city utilizing real-time traffic information would require a representation of the streets as features described by attributes.

Owing to the large amount of data associated with WFS, these web services tend to require fast Internet connections.

The NGDS Data Explorer extracts data from web services in order to facilitate compliance with USGIN-OneGeology specifications. By examining the attributes that describe features in a given service, it is possible to determine whether or not a given web service meets USGIN-OneGeology standards.

Section 2: Using the NGDS Data Explorer
The **NGDS Data Explorer** is accessible via a web browser of your choice. To access the **NGDS Data Explorer**, open your web browser and connect to the following URL:

http://data.geothermaldatasystem.org/

The application should appear in your web browsers as it does in Figure 1:

![Figure 1: The USGIN WFS Client interface](image)

From this interface, the following operations are possible:

- Load a [web feature service (WFS)](http://data.geothermaldatasystem.org/) and display said web service as a *layer* on the map; multiple web services may be loaded simultaneously
- Select features from web services that have been loaded
- To export attributes describing selected features to an [HTML](http://www.w3.org/TR/html401/) table (only one layer can be exported at any given time)

### Section 2.1: Loading Web Services via Search and Dropdown Menu

There are two methods by which [web feature services (WFS)](http://data.geothermaldatasystem.org/) may be loaded into the **NGDS Data Explorer**:

1. Search the **NGDS Catalog** for the desired web service and load the results as a layer
2. Select the web service from the Quick-Pick Data Services dropdown menu under Available Layers (Figure 1)
3. Manually enter a web service URL by clicking the URL button under Available Layers

To search the NGDS Catalog, take the following steps:

1. Enter your search terms into the Enter Search Term box (Figure 1); if necessary or desirable, specify a metadata field to which you wish to limit your search
2. Click Search
3. Click the desired result
4. Click Add Layer

To load a USGIN web feature service (WFS) via the Quick-Pick Data Services dropdown menu, take the following steps:

1. Click the dropdown menu under Available Layers
2. Click the desired web service

The web service will now appear as a layer on the map, listed as such under Available Layers. Click the Check Box beside the WFS layer you just added to show your data on the map.

Note that this method can only be used for web feature services (WFS) described by metadata records in the NGDS Catalog (http://search.geothermaldata.org/). If a given web feature service (WFS) is not in the metadata catalog, it will not appear in the dropdown menu.

See the USGIN Metadata Tutorial (http://usgin.org/content/usgin-metadata-tutorial) for more information about metadata.

Section 2.2: Loading Web Services via URL

Web services, including web feature services (WFS), are designed to be accessed via a web browser and, consequently, are accessible via URL just like any web site.

To load a USGIN web feature service (WFS) by manually entering a URL, take the following steps:

1. In a web browser of your choice, locate and access the REST page of the desired web service
2. Select and copy the URL of the REST page
3. In the NGDS Data Explorer, deselect any previous active map layers, if any, click the URL button under Available Layers and to the right of the dropdown box
4. In the field that appears, paste the URL of the desired web service REST page
5. Remove the following text from the URL of the REST page:
Append the following text to the URL of the REST page:

/WFSServer

Press the Enter key

Alternatively, you may achieve the same result by navigating to the web feature service (WFS) capabilities document by clicking the WFS link at the bottom of the REST page. Copy the URL of the capabilities document and paste it into the URL field in the NGDS Data Explorer; remove the string of characters to the right of, and including, the question mark (?). Press the Enter key.

The web service will now be listed as a layer on the map under Available Layers. Expand map layer(s) by clicking [+] Map Layers. Click the Check Box beside the WFS layer(s) you just added to display your data on the map.

After adding web feature services (WFS) as layers to the NGDS Data Explorer, you may remove them by refreshing the client using your web browser’s Reload Current Page button, or by clicking the desired layer and clicking the Remove Layer button.

Section 2.3: Exporting Data from the Data Explorer

Now that you have loaded a web feature service (WFS) into the NGDS Data Explorer, you can export the attributes describing some or all of the features in the service to an HTML table. Attributes can be exported in this way from only one web service at a time.

To export feature attributes, take the following steps:

1. Select any specific features for which you want to export attributes (optional) by clicking-and-dragging a bandbox around the desired features in the WFS Map window
   a. You can deselect all currently selected features by clicking Clear All Selected on the WFS Map toolbar (Figure 1)
2. Click the layer you wish to export under Available Layers
3. Click Create Table on the WFS Map toolbar

A new tab or window will open in your web browser, containing an HTML table. This table contains attributes for every feature you exported.

From here, you have two options:

1. Save the table as a discrete HTML document on the hard drive of your computer, accessible at any time:
a. In window or tab containing the HTML table you have just created, click **File > Save Page As...** in your web browser
b. Browse to the desired location
c. Type the desired name for your HTML document
d. In the **Save as type:** dropdown menu, select **Web Page, complete (*.html, *.html)**
e. Click **Save**

2. Copy and paste the table into an appropriate application, such as Microsoft Excel:
   a. In window or tab containing the table you have just created, click **Edit > Select All** in your web browser
   b. Click **Edit > Copy**
   c. Open a new document in the desired application
   d. Click **Edit > Paste**
   e. Click **File > Save As...**
   f. Browse to the desired location
g. Type the desired name for your document
h. Click **Save**

This completes the export process. Repeat the process for each layer you wish to export in this way.